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1.0 Program Description

This program can be used for downloading, creating and/or displaying SS3 waveform capture files.
The waveform data can be downloaded from the SS3 through the serial or Telnet service ports.
The program can also be used to view SS3 waveform files which are attached to email sent by the
SS3.

2.0 PC System Requirements

e IBM Pentium or higher (or compatible) PC.
e Microsoft Windows 2000 or higher.

3.0 Installation
This program can be installed launching the 'SS3_Waveform_Capture_Setup_vX_X_X.exe' file
provided.

Following are examples of the dialog boxes that will appear during the installation. Follow the
instructions in each box.

I*setup - Cyberex 553 Waveform Capture - |EI|5|

Welcome to the Cyberex 553
Wawveform Capture Setup Wizard

This wall install Cyberex 553w aveform Capture an your
complter

It iz recammendad that pou close all other applications befare
cantinuing.

Click Mext to continue, or Cancel to exit Setup.

st » [ I Cancel
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[*Setup - Cyberex 553 Waveform Capture

License Agreement
Pleaze read the following important information before continuing.

Pleaze read the following Licenze Agreement. “'ou must accept the terms of this
agreement before continuing with the installation.

Cyberex SOFTWARE LICENSE AGREEMENT 3

IMSTALLATION MOTICE: THIS 12 A CONTRACT. BEFORE YOL
DOWNLOAD THE SOFTWARE ANDIOR COMPLETE THE

INSTALLATION PROCESS, CAREFULLY READ THIS AGREEMENT. BY
DOVMLOADIMNG THE SOFTWARE ANDVOR CLICKING THE

APPLICABLE BUTTON TO COMPLETE THE INSTALLATION PROCESS,
WOU COMSENT TO THE TERMSE OF THIS AGREEMENT AMD YO
AGREFETO RE ROLIND BY THIS AGREEMERT IF 0L D0 BOT WiSH j

" | accept the agreement
l&ent

& | do not accept the agre:

< Back I [ I Caticel I

[+Setup - Cyberex 553 Waveform Capture

Select Destination Location
Where should Cyberexs 553 Waveform Capture be installed?

D Setup will inztall Cyberex 55 3 W aveform Capture into the following folder.

Tao continue, click Mest. If you would like to select a different folder. click Browse.

D:“Program Fi : farm Caphure Browse... |

Al least 3.4 MB of fee disk space is required.

< Back I Mest » [_: I Cancel |

[*Setup - Cyberex 553 Waveform Capture

Ready to Install

Setup iz now ready ta begin ingtaling Cyberex 553 'wavetorm Capture an your
computer.

Click Install ko continue with the installation, or click Back if you want to review or
change any gettings.

Destination location: |
[:4Program FileshCyberex 553 W avefarm Capture

Kl _>|_I
< Back I Inztall ‘EI Cancel |
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I+Setup - Cyberex 553 Waveform Capture — |EI|5|

Completing the Cyberex S53
Wawveform Capture Setup Wizard

Setup has finished instaling Cyberex 553 waveform Capture on
wour computer. The application may be launched by selecting
the inztalled icons.

Click Finizh to exit Setup.

¥ Wiew 553_\Wwaveform_Capture_lnstructions. doc

This setup program will install will put a shortcut on the Desktop and in the Windows
Start->Programs folder.

4.0 Opening Waveform Files

When the program is started for the first time, the main window will appear blank as shown below in
Figure 4-1.

SS3 waveforms will appear as the waveform files are opened. (See Figure 4-2.) Existing waveform
files can be opened by either by dragging and dropping into the Main Window or by selecting
File>Open in the main menu bar using the standard MS Windows practice. When this program is
used for downloading waveform capture data from the SS3, it automatically creates a waveform file
and opens it for viewing. The waveform file is saved on the hard disk. The download feature will be
discussed later.
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- Cyberex SuperSwitch 3 - Waveform Capture = ﬂ
File Wiew Help
| | 4
Figure 4-1 — The Main Window after Installation
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File Yiew Help
1000 % —
for” ™ 1 '>‘f"" " i ""-< _ ¥
Q000 Y o P —>< — e e '\.\ \ ~ o] — i W)
[ = > e | oK = < 51 ¥(b-c)
-1000Y — 51 Vic-8)
-240ms -200ms -160mS -120ms  -80ms  -4.0ms  0.0mS 4.0ms §0mS 120ms 160mS  200ms  24.0mS
0100 &,
Al AOAAA — sl
ooo A, L R S1 (k)
0100 & — =)
-240ms -200mSs 160mS -120mS  -80mE  -4.0mS  00mS 4.0mS 80mS  120ms  160mE  200mE  240mS
1000 —
] - — 52 %(a-h)
e e e
Ry S Pt - S ]
-1000Y — S2 Vic-8)
-240ms -200ms -160mS -120ms  -80ms  -4.0ms  0.0mS 4.0ms §0mS 120ms 160mS  200ms  24.0mS
0100 &,
ad A PO, WO a o Al A = S20Ey)
0000 & - - p—
-0100 A& T — S21(c)
-240ms -200mSs 160mS -120mS  -80mE  -4.0mS  00mS 4.0mS 80mS  120ms  160mE  200mE  240mS
1000 % T
- e — o
0000 v il o, - — ey 1 - Out Y(a-h)
,><:.__,/1, = D = l il - <A 1 out Wh-c)
-1000 % T T 1 — Out W(e-a)
-240ms -200ms -160mS -120ms  -G.0ms  -4.0ms  0.0mS 4.0m3 §0mS 120ms 160ms 200ms  24.0mS

‘ 06/14/2006 03:58:47.367 - Transfer due to User successfully completed

| I:WBASS 3 Wavetorm_CapturehFy_Wave_DemotS53 Download_007att

Figure 4-2 — The Main Window after Opening a Waveform File
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5.0

6.0

Selecting Views

When a file is opened, the "All Charts" view is the default view as shown in Figure 4-2 above. The
zero-time (0.0mS) line on the charts indicates the SS3's transfer trigger point. The Main Window
can be resized to any size or maximized to fill the screen using the standard MS Windows practice.

Other views can be selected by selecting them on the View menu as shown below.

v Cyberex SuperSwitch 3 - Waveform Ca
Filz | Wiew Help

Source 1 Amps gl E——
Source 2 Volks T
-5 Source 2 Amps
aukput Yalks -16.0ms  -12.0m!

............ ‘oltages
Currents

Motmnal Zoam

0 Zaom

-1000 A

-240m=  -200ms -16.0ms  -12.0m:

Figure 5-1 — The View Menu

Using the Zoom Box

The time scale and position of the charts can be changed by opening the Zoom box. The Zoom box
can be opened by selecting View—>Zoom or by right-clicking on a chart.

x

Default |
e

Current

Scale
—

Tirne Position

Figure 6-1 — The Zoom Box

When the Zoom Box is opened, the two slider controls control the time scale and position of the
charts. These controls can be adjusted either by the mouse or more conveniently by the arrow keys
on the keyboard.

The Left and Right arrow keys make the zero-time line on the charts move left and right,
respectively. (This also moves the horizontal slider left and right.)

The Up and Down arrow keys make the waveforms appear to zoom in and zoom out, respectively.
(This also moves the vertical slider up and down.)

The "Def" button on the Zoom Box sets the charts back to the default time scale and position.
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7.0 Opening Multiple Windows

8.0

Individual charts can be opened in separate windows by simply double-clicking on the chart you
want to open. The time scale and position can be independently adjusted in each window as
desired. For example, in the screenshot below, the smaller window was opened by double-clicking
the Output chart at the bottom of the larger window. The Zoom Box was then used to zoom in on
the smaller window.

The program can also open multiple unrelated waveform files by selecting File>New in the menu

bar.
[-Cyberex Su | ﬂ
File Wiew Help
1000 ¥
0500 Y 4— e
o . /’ /"a — S1 V(ah)
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Figure 7-1 — The Zoom Box

The Most Recently Used File List

|:"WB%S55 3_Waveform_CapturehFx_Wave_DemotS53_Download_007a.tt

The program saves the paths to the last eight files opened in a Most Recently Used (MRU) file list
as shown below.
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9.0

10.0
10.1

frCyberex SuperSwitch 3 - Waveform Capture: 04,/03/2007 10:00:32.987 - Transfer d ] 4
W View Help
Login
Lagout

Downlzad

Mew
Dpen

Explorer

Prinkt

form_Capture'bal Downloads)Sh-12345-6 Apr 03 2007 10_00 &7 ALRM Transfer due to Retran ko Pref successfully completed. bxt
F:\WEYSS3_Waveform_CaptureibakiS3\Downloads! Sh-12345-6 Apr 02 2007 11_47_36_795 ALRM Transfer due to Retran to Pref successfully completed. bxt k
F:1wEY353_Waveform_Captureibakis3Downloads)sh-12345-6 Apr 02 2007 11_47_30_797 ALRM Transfer due to Dead Source successfully completed. bxt
F:1WE1S53_Waveform_Captureibakis3DownloadsiSh-12345-6 Apr 02 2007 11_44_20 692 ALRM Transfer due ko Retran ko Pref successfully completed.kxt
F:1WEYS53_Waveform_Captureibakl 53 Downloads)SN-12345-6 Apr 02 2007 11_44_05_509 ALRM Transfer due ta PO Yellow Hi Yolt successFully completed. bxt B
F:\WEYS53_Waveform_Captureibakls3Downloads)Sh-12345-6 Apr 02 2007 11_44_05_375 ALRM Transfer due to Retran ko Pref successfully completed. bxt

F:1wEY353_Waveform_Captureibakis3Downloads)Sh-12345-6_Apr 02 2007 11_44_03_378 ALRM Transfer due to Retran to Pref successfully completed. txt
F:WEYS53_Waveform_Captureibakis3Downloadsiapr 02 2007 11_44 03373 ALRM Transfer due ko Retran ko Pref successfully completed.txt
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| 0470342007 10:00:32.987 - Transfer due to Retran to Pref successfully complated | FAWBNSS3 Wavetorm_Capturshbakha 3\ Downloads\SN-122345-6 Apr 02 2000 2

Figure 8-1 — The MRU File List after Opening Waveform Files

Printing Charts

The chart images can be printed selecting File=>Print on the main menu bar. Generally, the
Landscape printer setting will give the best results.

Downloading Data from the SS3

The Initial Login

An initial login must be performed before data can be downloaded data from the SS3. The
password for the SS3 "admin" user is required. Once you are logged in, you have the option of
logging out between uses, or remaining logged in for future uses.

To log in, click File->Login on the main menu bar. The Login dialog box will open as shown below.

5I

User: W
Pazzward: I

Ok I Cancel I
Figure 10-1 — The Login Dialog Box

Enter the SS3 "admin" user password and click OK. The program will retain this login status until a
logout is performed. To log out, select File->Logout on the main menu bar.
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10.2 Selecting the SS3 Connection

After the login has been performed, the File->Download main menu item should become enabled.
To select the SS3 connection, click on File->Download on the main menu bar. The SS3
Connection dialog box should appear as shown below.

ﬂ
Sernial Port or IP Address ————————————————
IEDM‘I j | Cornect |

Save | Hemovel wieh | IF'Configl

Figure 10-2 — The SS3 Connection Dialog Box

When the program is installed, it is configured with only one comm. port (COM1) as shown above.
Comm. ports and IP addresses can be added, removed and saved by the program so that they will
be available when the program is closed and reopened later.

To add a new comm. port or IP address, type it in over the one showing in the combo (dropdown)
box. (See Figure 10-2 above.) Once the item has been changed, the Save button (below the
combo box) will become enabled. You can then save the new port or address in the list by clicking
the Save button. To see the items in the list, click on the down-arrow button on the right-hand side
of the combo box as shown below in Figure 10-3. Then you can select the item you want to use.

. 553 Connection x|

Serial Port or IP Address

10.75.35.70 Ping | Connect|

10.75.35.69 Web | IP Configl

10.75.35.71
10.75.35.72
COm1
COmz

Figure 10-3 — The SS3 Connection Dialog Box

To remove an item from the list, select the item and click the Remove button under the combo box
(Figure 10-2).

After an IP address has been selected, the Ping button can be clicked to test the connection by
pinging the SS3. Clicking the Web button will open the SS3's web server, if it is enabled on the
SS3. Clicking the "IP Config" will show the TCP/IP settings of the PC.

Note: To download waveform data from the SS3 using the Telnet service port, the TCP/IP settings
on the PC and SS3 must be set up properly and the Telnet must be enabled on the SS3. To
download waveform data from the SS3 using the serial service port, no special settings are required
on the SS3, (except for the Waveform Capture feature, which must be enabled on the SS3 in either
case).

10.3 Initiating the Connection to the SS3 and Downloading the Waveform List

After the SS3 connection setting has been selected, click the Connect button to initiate the
connection to the SS3. The SS3 Service Port Terminal window should open as shown below in
Figure 10-4. The program should automatically log in to the SS3, read the SS3's serial number, and
download the Waveform List as shown below.
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10.4

"z 553 Service Port Terminal: 10.75.35.70 - Serial No. 12345-6 i [m] 5]
OEonnection State OLogin State Ping Disconnect Cloze
r~ Teminal Interface
| [Hper File Open Folder
r—*waveform Filename
. waveform List
Capture data lost. ;I
Apr 0Z 2007 11:43:57.377 ALDM Transfer due to I'Q Tellow Hi Wolt successfully completed
Capture data lost.
1) Apr 0Z Z007 11:44:03.3272 ALEM Transfer dus to Retran to Pref successfully completed
Capture data available.
2} Apr 0Z Z007 11:44:032.502 ALPBM Transfer due to PQ Yellow Hi Volt successfully completed
Capture data awvailable.
3) Apr 0Z Z007 11:44:20.6%2 ALBM Transfer due to Retran to Pref successfully completed
Capture data available.
4) Apr 0F Z007 11:47:30.737 ALEM Transfer due to Dead Source successfully completed
Capture data available.
E) Apr 0Z Z007 11:47:326.792 ALEM Transfer dus to Retran to Pref successfully completed
Capture data available.
S0 Apr 02 Z007 10:00:2Z.927 ALPBM Transfer due to Retran to Pref successfully completed
Capture data available.
= i

| Connected: 000032 | Telnet  [10.75.35.70

Figure 10-4 — The SS3 Service Port Terminal Window

The STS transfer events with waveform data available will appear as numbered items in the
Waveform List. In the example above, there are six events (numbered 1 through 6) with waveform
data that can be downloaded from the SS3 and viewed by this program.

Downloading Waveform Data an Event

To download the waveform data from one of the transfer events, double-click on the event and click
on the popup menu item that appears as shown in the example in Figure 10-5 below. (You can also
select an event by using the arrow keys and the Enter key.)
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- §53 Service Port Terminal: 10.75.35.70 - Serial No. 12345-6 i [m] 5]

o Connection State o Login State Fing Dizconnect Close

— Teminal Interface

| Hpen File Open Folder

—* aveform Filename

. i avefarm List

Capture data lost.
Apr 0 2007 11:43:57.377 ALPM Transfer due to PQ Tellow Hi Volt successfully completed
Capture data lost.
1) Apr 0F Z007 11:44:03.378 ALEM Transfer due to Retran to Pref successfully completed
Capture data available.
Z) Apr 0Z Z007 11:44:02_ 509 ALDBM Transfer due to PO Yellow Hi Wolt successfully completed
Capture data available.
2) Apr 0FZ Z007 11:44:20.69Z ALEM Transfer dus to Retran to Pref successfully completed
Capture data available.
i) Apr 7 11:
Capture data awailable.
5) Apr 02 Z007 11:47:36.735 ALEM Traf
Capture data awvailakble.
&) Apr 03 Z007 10:00:32.2987 ALBM Transfer due to Retran to Pref successfully completed
Capture data available.

-

| Connected: 000022 | Telnet  [10.75.35.70 |

Figure 10-5 — Selecting a Waveform from the List

After the event is selected and the waveform download is initiated, the waveform data should be

seen filling the upper "Terminal Interface" box as shown below in Figure 10-6.
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"z 553 Service Port Terminal: 10.75.35.70 - Serial No. 12345-6 =10l x|
O Cannection State O Login State Ping Disconnect Cloze
 Teminal Interface
0,1,1,0,-1,0,-620,77,549,0,0,0,-447,-209,664 ;l
0,1,1,0,-1,0,-595,19,581,1,1,0,-414,-255,678
1,1,1,0,-1,0,-59,-31,606,1,1,0,-288, 300,688
1,1,1,0,0,0,-544,-85,634,1,1,0,-347,-327,682
1,1,1,0,0,0,-513,-140,661,1,1,0,-298,-361,665
0,1,1,0,0,0,-485,-194,677,0,1,0,-254,-399,558
0,1,1,0,0,0,-44%,-238,691,0,1,0,-208,-43E,649
5,5,6,0,0.1,-332,-297,713,1,3,1,-155,-473,633
1,1,1,1,1,3,-250,-338,692,0,0,0,-101,-507,6132
1,1,1,1,1,1,-300,-375,678,0,0,0,-48,-538,593
1,1,1,1,1,1,-255,-411,671,0,0,0,5,-573, 566
1,1,1,1,1,1,-207,-446,660,0,0,0,64,-60Z E4Z
i g5
-
| Open File Open Folder

W aveform Filename

|_Capture\bak\53\Downloads\SN-1 23456 Apr 02 2007 11_47_30_797 ALRM Transfer due to Dead Source successfully complated bt

W aveform List

Capture data lost.

Capture data lost.
1) Apr 0Z Z007 11:44:03.3272 ALEM Transfer dus to Retran to Pref successfully completed
Capture data available.

Capture data awvailable.
3) Apr 0Z Z007 11:44:20.6%2 ALBM Transfer due to Retran to Pref successfully completed
Capture data available.
! 07 11:47 75
Capture data avai le.
E) Apr 0Z Z007 11:47:326.792 ALEM Transfer dus to Retran to Pref successfully completed
Capture data available.
S0 Apr 02 Z007 10:00:2Z.927 ALPBM Transfer due to Retran to Pref successfully completed
Capture data awvailable.

M Transfer due to Das v ocompleted

Apr 0Z 2007 11:43:57.377 ALDM Transfer due to I'Q Tellow Hi Wolt successfully completed

2} Apr 0Z Z007 11:44:032.502 ALPBM Transfer due to PQ Yellow Hi Volt successfully completed

=

| Connected: 000553 | Telnet  [10.75.35.70 |

4

Figure 10-6 — After Waveform Data for an Event is Downloaded and Saved in a File

The downloaded waveform data is also saved in a file with the filename derived from the SS3's
serial number and the event text (Serial Number/Date/Time/Description) as can be seen in the
example above. All files are downloaded into the "Downloads" subfolder under the application's
folder. If a file with the same name already exists, like if you download the same event twice, the

old file is overwritten.

After the waveform data has been downloaded and saved into a file, the main window will be

immediately updated with the new waveform images.

After downloading a waveform file, the file can be opened in your text editor by clicking the "Open
File" button. When the "Open Folder" button is clicked, Windows Explorer will open with the

waveform file selected.

While the SS3 Service Port Terminal window is connected to the SS3 (as shown above), it can be
used as a terminal emulator by entering service port commands into the small textbox at the bottom

of the "Terminal Interface" frame.
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